Major Problems With ICONex_Connect AND BEA Token!

Hello folks,

I have been trying to get help on Telegram on this issue for 24 hours now. I may not be a big P-Rep but I have worked hard to build on Icon and do things that help the network. I am going to take this in stages here, so bear with me. First of all the BEA Coin.

Seven, months ago I created the BEA token as a PoC for our family business. Considering that I’ve been involved with Icon in one form or another since the ICO I thought that it would be a really nice albeit small gesture to increase the step price for the Bea Token in order to reward the whole network for giving us the opportunity to do this. So for the Bea Token I set the step price/fee at a minimum of 300,000 steps and a maximum of 500,000 steps. This should be doable from ICONex mobile and I was under the impression that this latest fix fixed the transaction fee issues for mobile but I was sadly mistaken.
Here is a send for the BEA token that is done from the Chrome extension. The sends work for the Chrome extension because the Chrome extension allows for higher step fees. The mobile Iconex wallet does not.

As you can see the Step Limit of 507,900 Steps and the step Fee of 507,900 Steps are satisfied and the transaction is completed. The real issue is that on ICONex mobile the step fee and step limit don’t adjust and the latest update from Velic hasn’t addressed the issue. I have had an open ticket on Github on this issue for 5 or 6 months and I realize that we are tiny P-Rep and a small real business that is doing the PoC but from mobile this is what I get when I try to send a Bea token:

bea

The step limit is not updated to the contract the token is built on or calls for which is higher and the transaction never goes through. Now, why are Mobile sends so important? Because the BEA token is built for a real small business where folks will use them as gift certificates redeemable of services in the business and they need to be able to send from the ICONex wallet back to the business at the cash register from their mobile devices.

I have reached out to everyone I know for the last 6 months on Telegram and the only team that has responded is ReliantNode who have already fixed the issue in their wallet that is coming out soon, however I feel this issue should also be fixed for the official wallet as well considering it’s the official wallet.

So question one is, how in the heck do we get through to anyone at Velic to actually fix this since Velic doesn’t seem to respond to anyone. I would sincerely be thankful for any help any of the higher ups can give to get this issue solved because A) I may not be a big a P-Rep but I am working my tail off trying to get the real world to use Icon and am not being supported by the wallet maintainers and have no way to let them know there is an issue, and B) this makes Icon look bad because the token won’t work, and C) It makes my business look bad because the token won’t work.

So, please, someone help me get ICONex fixed with this issue. The Bea Token should be able to be sent from mobile. I can’t expect customers to bring a PC or laptop in order to redeem their tokens they are paying for.

Maybe I am an idiot but I set the fee higher than the default because I wanted to reward the network for giving us the opportunity and now it’s useless until Iconex is fixed. I know it may not be a priority for the big money folks that are calling the shots and doing the sexy things but if we want Icon to succeed shouldn’t a token created on the network by an iconist and now P-Rep operator (me) be a priority as well?

Second:

The update to ICONex has absolutely broken something in ICONex_connect which is is the html interface to transfer tokens on the web. Up until the update my second project keekee.io which is an Icon powered social site was able to send transactions through Iconex_connect to other users on the platform. I was also really freaking close to having ICONEX_connect working within Facebook as a way to get ICX moving among the vast Facebook community. After the update the other day it now will not work. Here are the screen shots ALONG with the errors.


See that works to that point.
Now this:

It loads the json data and tries to send the transaction.

However when one clicks the “load transaction” and inputs the wallets password to complete the final step all we get is this:

Which never sends or completes the transaction. Therefore it’s broken. My code hasn’t changed and there is no documentation on why this is occurring. Here is the developer output from that window and it looks as if the latest update has broken or changed the reactOS bundles:

Here is full error output:
Uncaught TypeError: Cannot read property ‘params’ of undefined
at SendTransaction.render (popup.bundle.js:140145)
at ReactCompositeComponentWrapper._renderValidatedComponentWithoutOwnerOrContext (popup.bundle.js:86301)
at ReactCompositeComponentWrapper._renderValidatedComponent (popup.bundle.js:86324)
at ReactCompositeComponentWrapper.performInitialMount (popup.bundle.js:85864)
at ReactCompositeComponentWrapper.mountComponent (popup.bundle.js:85760)
at Object.mountComponent (popup.bundle.js:91682)
at ReactCompositeComponentWrapper.performInitialMount (popup.bundle.js:85873)
at ReactCompositeComponentWrapper.mountComponent (popup.bundle.js:85760)
at Object.mountComponent (popup.bundle.js:91682)
at ReactCompositeComponentWrapper.performInitialMount (popup.bundle.js:85873)
popup.bundle.js:86247 Uncaught (in promise) TypeError: Cannot read property ‘_currentElement’ of null
at ReactCompositeComponentWrapper._updateRenderedComponent (popup.bundle.js:86247)
at ReactCompositeComponentWrapper._performComponentUpdate (popup.bundle.js:86226)
at ReactCompositeComponentWrapper.updateComponent (popup.bundle.js:86147)
at ReactCompositeComponentWrapper.performUpdateIfNecessary (popup.bundle.js:86063)
at Object.performUpdateIfNecessary (popup.bundle.js:91793)
at runBatchedUpdates (popup.bundle.js:92550)
at ReactReconcileTransaction.perform (popup.bundle.js:94529)
at ReactUpdatesFlushTransaction.perform (popup.bundle.js:94529)
at ReactUpdatesFlushTransaction.perform (popup.bundle.js:92489)
at Object.flushBatchedUpdates (popup.bundle.js:92572)

So what has changed? It looks like it’s now broken and I need help. I may be a tiny little P-Rep but I have worked my tail off getting this stuff together to help build Icon and actually use it and please someone help me get this BEA token working on the official wallet. And, second what in the heck has happened to ICONex html interface and can someone help me actually get it working again?

I feel like the carpet has been pulled totally from under me and that no one is listening to a P-Rep (me) that has worked very hard and is just being ignored.

Thank you and good day,
Dusty

3 Likes

Thank you Min and Bong and Spl3en for getting some help on this. I really, really appreciate it from the very bottom, top and complete total of my heart. Thank you!

ICONex Mobile apps (iOS/AOS) have been updated.

Thank yo so much Bong. We really appreciate it.

1 Like

How’s progress mate?