I can't connect ledger to iconex NOV 2021

Hi, I can’t connect the iconex app to the Ledger. I have upgraded the ledger firmware. I have tried brave and chrome and Edge. I have restarted my computer. I have installed the icon app on Ledger Live with the manager and it is there installed on my device. I select ‘Connect to Ledger’ in the wallet app. and it says ‘Failed to Connect’ in red. I retry but no luck . The screen seems to blink , but does not connect . Is this a known problem at the moment? Please provide help. Thank you so much in advance

The wallets to use now are Hana as chrome/brave extension and myiconwallet on mobile devices. To see the download links look for wallets on the icon.foundation page!

Ok, Thank you very much for the response. I will look into it

Same issue here. Does not connect to Ledger. Tried using Hana, but still no bueno! Hopefully, it is just a temporary kink.

Hey! for me the issue was changing the port on my PC, just keep changes ports and one eventually works.